Ancestry.com

Site Maintenance last Saturday morning

Posted by Eric Shoup on February 3, 2009 in Ancestry.com Site, Site Status

Our data center provider performed routine maintenance on their infrastructure between midnight and 6am Saturday morning.  Due to some unexpected issues that arose related to this maintenance, we took protective actions to take a bank of servers offline.  Other companies hosted in that facility did the same.  As a result, parts of our Ancestry sites were down from 1:05am to 5:45am MST on Saturday morning while the servers were being brought back online.

Sorry for the delay in getting this information out to you as well as any inconvenience this may have caused.

Regards

Eric Shoup
VP Product

17 comments

Comments
1 AlysFebruary 3, 2009 at 9:18 pm

Downloaded the new Starter Edition but it does not work. It keeps sending error messages. First, that it has been detected that something has interferred with keys then the second one says I cannot use this SE because I am not connected to the Internet but of course I am connected. Should I delete and reload?

2 LantrixFebruary 3, 2009 at 11:20 pm

Thanks Eric for the post to advise on the issues that occurred.

Is there any way to start providing simple outage details via your twitter feed (http://twitter.com/ancestrydotcom) in addition to the already provided blog post information?

Near Realtime outage information, well sooner than 3 days later ;-) – would be very appreciated and may even help in reducing some of the negative comments I’ve seen on this site! :-)

It could be as simple as a tech lead in your first response team who has access to the account via an application such as tweetdeck!

3 Eric ShoupFebruary 4, 2009 at 8:52 am

Alys- I have forwarded your comment to the Family Tree Maker Product Manager. Hopefully he can answer your question.

Lantrix- Good suggestion. We are fine-tuning our internal protocol for getting this information out more quickly. Using twitter is a good suggestion. Thanks.

4 Sherrie BarberFebruary 4, 2009 at 9:25 am

Is there a reason why moving around from place to place in Ancestry has now slowed down to a slow crawl? Don’t tell me it’s because I haven’t deleted Spyware, Temporary Internet files, cookies etc…….I’ve done it all and what once was quick has now gone to less than a slow crawl. Is this suddenly due to “routine maintenance on their infrastructure” (your quote)? I’m timing the move from place to place and I wait up to 2 minutes just to move from one data base to another!! Sherrie

5 Shirley BarrowFebruary 4, 2009 at 9:31 am

I think that in the almost five years
that I have been a member at Ancestey.com. My Family Tree’s have grown a lot. I appreciate everything that has been added to help me found more of my family. thanks,sweetthing68

6 Stuart GourdFebruary 4, 2009 at 12:19 pm

Site is very slow again today. Also, hints for related trees are not showing up reliably. Sometimes they do show up if I refresh the page, sometimes not. I have been getting around this by finding someone else’s tree and choosing the “Add this person to my tree” button in the past, but that does not appear to be working at all today.

Great idea to put updates on twitter. Generally, the site is great and it seems like Ancestry is listening to comments and suggestions. Wish there was a way to clear up this latest (2-3 weeks or so) bout of slowness and unresponsiveness. Keep slogging away, we users will try to help.

7 Eric ShoupFebruary 4, 2009 at 12:24 pm

Sherrie & Stuart-

Would you be open to us calling you to get more details on your experience? If so, please email me your contact info at eshoup@tgn.com.

We have a development team actively working on improving our site performance. Input on where exactly you are seeing the issues, what browser you are using, etc. would be of great help.

Thanks very much.

Eric

8 robertstidolphFebruary 4, 2009 at 12:27 pm

I agree with the previous posts about how slow the system is. It is a major problem and see no improvement at all.

9 John W. BishopFebruary 4, 2009 at 4:27 pm

Its doing it again cannot add records as well as being slow

10 John W. BishopFebruary 4, 2009 at 4:43 pm

It’s adding records again what’s going on ?

11 Brian BallewFebruary 5, 2009 at 1:05 am

I just spent over an hour transferring info on ten people from a census report to their individual pages. This is ridiculous!!!!! The problem is not my machine. I’m totally wireless and have more memory than is probably legal on an XP platform. I don’t have this ‘slow’ problem on any other commercial site.

12 Elizabeth McCloyFebruary 5, 2009 at 2:23 pm

I have been trying to update the One Family Tree with my contact information that was somehow removed when I loaded the tree to your site. I just keep getting err messages. Why? I followed all the instructions you sent me to update the contact info and it won’t let me in. Betty

13 John W. BishopFebruary 6, 2009 at 6:48 am

The slow response from the site is still very slow trying to do any functions with your tree.As of right now it is running fairly well at 7:39 a.m. c.s.t.In late evening it runs at a snail pace.Seems to me there is a hardware deficiency needing more faster and larger servers.Are even a large main frame.

14 BonnieFebruary 11, 2009 at 4:04 pm

Just talked to ancestry.com
They act like the problems I am having with the site being slow, error messages and just doesn’t search is a small problem. Do you all think this is a big problem?

PLEASE START CALLING AND INSISTING THEY FIX EVERYTHING.

DO YOU THINK WORLD DELUX MEMBERS SHOULD PAY THE FULL PRICE WHEN ANCESTRY.COM IS ALLOWING ALL USERS TO ACCESS WORLD DELUX.

I JUST WANT MY FAST SEARCHES BACK NOW. NO MORE EXCUSES ABOUT WE ARE WORKING ON IT.

30 YEAR RESEARCHER AND I KNOW HOW ANCESTRY.COM WORKED IN THE PAST 9 YEARS

MY SEARCHES SLOWED TO A STOP LAST NIGHT. TODAY I WAS WORKING IN THE DROUIN COLLECTION AND NOTHING WAS HAPPENING. I TYPE AND NO WORDS SHOW, THEN I CANNOT SCROLL DOWN THE PAGE AND THEN I GET A TRY LATER MESSAGE WE ARE HAVING TEC. PROBLEMS, THEN THE ATTACH RECORDS ON MY TREE STOPS.

ARE YOU ALL WITH ME ON THIS?

I HAVE BEEN WITH ANCESTRY FOR MANY YEARS. I FEEL SORRY FOR THE NEW USERS THAT THINK THEY DO NOT KNOW HOW TO USE THE SYSTEM WHEN IT IS THE SYSTEM THAT IS BAD.

PLEASE START CALLING IN AND LETTING ANCESTRY.COM KNOW HOW BAD IT IS.

NO MORE CLEAN THIS OUT OR RESET THIS THOSE ARE ALL SUGGESTIONS TO KEEP US HAPPY AND THEY DO NOT WORK!!!!!!

ANCESTRY.COM DOES NOT WORK!!!!!

BONNIE

15 Norma HowardFebruary 12, 2009 at 1:09 pm

I cannot access the family tree chart now. When I view my personal person page, My mother and father is blank. It does not show their names and pictures. All was working fine until a few days ago. What is happening?

16 SteveFebruary 14, 2009 at 4:39 pm

I’m glad I’m not the only one with the slowness problem. It’s ridiculous these days, I just can’t get any research done. For the price we pay for subscriptions, how about some better servers? The ones you’ve got certainly can’t handle the current membership.

17 Tony CousinsFebruary 18, 2009 at 9:46 am

I think a black hole has swallowed all of the Ancestry / TGN VPs and product people – where are the responses to all the complaints – or is it impossible to defend?

TonyC

Comment on this articleCommenting is open until Tuesday, 17 February 2009

We really do appreciate your feedback, and ask that you please be respectful to other commenters and authors. Any abusive comments may be moderated.

Add comment

Looking for help with a specific problem? Try contacting Customer Service.

Discuss more Ancestry.com topics in the Message Boards.

About the Ancestry.com blog

Here you will find informational, and sometimes fun, posts from the folks behind the scenes here at Ancestry.com. We hope you’ll notice just how passionate we are about family history and about the products we’re building to help connect families over distance and time.

Visit Ancestry.com
Notifications

Receive updates from the Ancestry.com blog Learn more